Back to overview
Downtime
Geo interactive os unresponsive
Jun 07 at 09:24pm BST
Affected services
geointeractive.online
Geo intractive OS.
Resolved
Jun 07 at 09:29pm BST
we have fixed it
Affected services
Created
Jun 07 at 09:24pm BST
our bot is down we are looking into it
Affected services